Mac Remote Desktop Commandline with BIg Sur

Stephen Barrett 11 Reputation points

Ever since I updated to Big Sur, a script I have no longer works with Remote Desktop Client for Mac.

Basically the script, goes to AWS and looks up a private ip address of a specified machine instance. It then SSH tunnels to that private ip address on port 3389 and binds it locally to port 59000. It then launches remote desktop with a command similar to

open "rdp://full%20address=s:localhost:59000&username=s:administrator&prompt%20for%20credentials%20on%20client=i:1&smart%20sizing:i:1&screen%20mode%20id:i:1"

This was all working great under Catalina (and previous iteration of MacOS). Now with Big Sur, it no longer works. It gets an error:

The file /Users/REDACTED/rdp:/full%20address=s:localhost:59000&username=s:administrator&prompt%20for%20credentials%20on%20client=i:1&smart%20sizing:i:1&screen%20mode%20id:i:1 does not exist.

Its as if Big Sur/Terminal no longer knows how to handle an rdp URI.

Is there some new parameter or configuration that needs to be done with Big Sur now? I am running the latest RDP client 10.6.6 and also tried with the last few versions.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,142 questions
{count} vote

3 answers

Sort by: Most helpful
  1. Raffaele Vigliotti 26 Reputation points

    If i replace // with //// in the URI, I don't get that error anymore although the Mac RDP Desktop Client throws an "The URL is not valid. Notify your network administrator." Error - I also tried with the example here:

    1 person found this answer helpful.
    0 comments No comments

  2. Leila Kong 3,691 Reputation points

    Hello @Stephen Barrett ,

    1.Microsoft Remote Desktop uses the URI scheme rdp://query_string to store pre-configured attribute settings that are used when launching the client. The query strings represent a single or set of RDP attributes provided in the URL. The RDP attributes are separated by the ampersand symbol (&).

    Have you configured the GPO for RemoteApp Programs in Group Policy?


    2.There is a new beta version released which you could have a try:


    Best regards,

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  3. Nils Hjelte 0 Reputation points

    For MacOS sonoma you need to escape the : characters, as described here:

    eg rdp://

    0 comments No comments