Pipeline Nuget Restore: Failed authentication to organization nuget feed

Greg Pringle 31 Reputation points
2020-06-25T20:47:54.567+00:00

I am trying to setup a pipeline in devops to build a nuget package of an assembly. I select feeds in my nuget.config and it almost works but I get an error authenticating to a feed that is in our organization.

According to the tooltip it says for feeds in this organization/collection leave credentials blank; the builds credentials are used automatically.

The error I get is: {feed url}: Unable to load the service index for source {feedurl}. Response status code does not indicate success: 401 (Unauthorized). Where feed url is my feed.

This feed has permissions to allow both the project build service and the project collection build service How can I debug this?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,574 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Monalla-MSFT 12,771 Reputation points
    2020-06-25T22:20:29.587+00:00

    Hello GregPringle-1682,

    Azure Devops is currently not supported on Microsoft QnA.

    The Azure DevOps team and community are active and answering questions on Developer Community  

    Can you please post your question there instead? This forum is specifically for Azure Dev Tool Integration questions.

    You can also ask for help here Stack Overflow Devops.

    Thanks

    If the above response helped, please "Mark As Answer" and "Upvote" the same.

    0 comments No comments