Failed to Download the Vault Credentials File

Patrick Horan 1 Reputation point
2020-06-26T18:46:41.913+00:00

I'm trying to add a new machine to my backup vault. When I go to Properties, check the box for using the latest MARS agent and click download I'm met with the error noted in the subject.

I've tried Internet Explorer, Edge, Chrome and Firefox. I've tried clearing the cache and cookies on all of them to no avail.

I'm hoping there are more advanced steps I can take than the paltry ones I've seen in every other thread I've found.

Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
1,191 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Leon Laude 85,726 Reputation points
    2020-06-26T18:51:31.547+00:00

    Hi,

    It works for me fine, so it doesn't appear to be a major issue within Azure itself.

    You could try downloading the vault credentials file with Azure PowerShell by using the Get-AzureRmBackupVaultCredentials PowerShell cmdlet.

    Syntax:

    Get-AzureRmBackupVaultCredentials [-TargetLocation] <String> [-Vault] <AzureRMBackupVault>  
     [-DefaultProfile <IAzureContextContainer>] [<CommonParameters>]  
    

    Best regards,
    Leon

    0 comments No comments

  2. Patrick Horan 1 Reputation point
    2020-06-26T19:10:34.93+00:00

    I'm afraid I'm not very good with Powershell. When I run that command on the server I wish to backup, I receive a notice that the term Get-AzureRmBackupVaultCredentials is not recognized...