Azure App Service remote debugging fails to load modules

Troy Hughes 1 Reputation point
2021-05-25T23:45:36.047+00:00

In the past I've never had any issues remote debugging my Windows base Azure Web App. It's been some time since I need to do remote debugging but I cannot get modules to load or breakpoints to be hit. I'm using VS 2019 (16.10.0) and it seems to connect to the debugger just fine but I am unable to do any useful debugging tasks.

  • I have a Debug version of my app deployed.
  • I've made sure there are firewall exceptions on my dev machine via port and application rules just to make sure.
  • I have reinstalled VS 2019 on one machine twice now.
  • I've experience this behavior on 3 separate machines now, two using my user account and one a coworker tried from.
  • One machine I just did a clean install of Windows and VS 2019.
  • Additionally, I've tried swapping out the version of msvsmon.exe on my dev machine to a number of older versions and even pulled the version from my web app using Kudu.

I've been trying to search for recent issues online but I'm unable to find anything. Digging for an answer online, I've checked every setting and recommendation I can find. All attempts to fix this result in the same behavior. I've run out of things to check at this point. Any help would be appreciated.

Visual Studio Debugging
Visual Studio Debugging
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Debugging: The act or process of detecting, locating, and correcting logical or syntactical errors in a program or malfunctions in hardware. In hardware contexts, the term troubleshoot is the term more frequently used, especially if the problem is major.
912 questions
{count} votes