SQL Server Integration Services : Object reference not set to an instance of an object.

Lisa Andrews 1 Reputation point
2021-05-26T15:24:46.007+00:00

I have been trying to upgrade our SSIS packages from BIDS to VS 2017 using SSDT. I have everything over and can run the packages successfully in VS2017. I set up the SSIS DB catalog on the SQL Server (version 2017). When I right click a SSIS package in VS2107 and select Deploy, I fill in the appropriate fields and point to the SQL server. It goes through the steps and then fails at the end with this message:

TITLE: SQL Server Integration Services


Object reference not set to an instance of an object. (Microsoft.SqlServer.IntegrationServices.Wizard.Common)

I have researched for two days and have been unable to determine how to correct this problem.

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,412 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Yitzhak Khabinsky 24,566 Reputation points
    2021-05-26T15:36:29.613+00:00

    Hi @Lisa Andrews ,

    It is very possible that you bumped into a bug in the VS2017.
    There is a ticket on it here: unable-to-deploy-ssis-packages-from-visual-studio 2017

    What you can do is to copy *.ispac to the SSIS run-time server and deploy it locally in SSMS via 'Deploy Project...' menu entry option.
    Please see a screen shot below.

    As a long term solution, I would suggest to start using VS2019 and SQL Server Integration Services Projects extension.
    Download link: SQL Server Integration Services Projects

    99887-ssis-deploy-ispac-2021-05-26-113745.png

    0 comments No comments

  2. ZoeHui-MSFT 30,411 Reputation points
    2021-05-27T02:00:06.66+00:00

    Hi @Lisa Andrews ,

    As YitzhakKhabinsky said we'd suggest that you may use the newest VS2019 to see if it could resolve the issue.

    Here is also a work around to build the project and then navigate to the bin folder and double click the .ispac to open the SSIS deployment wizard outside of Visual Studio (if ispac file extensions are mapped to the Deployment Wizard).

    If the issue still occurs in VS2019, please post the issue here, if the issue is mentioned several times, the product team will help to resolve the issue.

    Regards,

    Zoe


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    Hot issues October