I can search in my VM but when i click on any result it does not open and says site took too long to respond?

Kartik 1 Reputation point
2021-06-18T09:56:38.187+00:00

I made a new VM using Concierge Subscription but Then I tried opening internet. I was able to search but when I opened a result it did not open. And showed me error site took too long to respond. I tried changing DNS but suddenly my VM stopped then I had to make a rule of port 3389. I tried fixing it with changing proxy settings to detect automatically. Also windows shows internet access still I cannot open any webpage. Also windows troubleshooter says connection between your access point, router, or cable modem and the Internet is broken.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,092 questions
Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,136 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. GitaraniSharma-MSFT 47,011 Reputation points Microsoft Employee
    2021-06-22T12:39:50.3+00:00

    Hello @Kartik ,

    Apologies for the delay in response.

    Please refer the below troubleshooting doc to check any NIC or connectivity issues:
    https://learn.microsoft.com/en-us/azure/virtual-network/troubleshoot-vm-connectivity#azure-vm-cannot-connect-to-the-internet

    NOTE : Any network configuration (DNS, static IP etc.) must be done from the Azure portal and not from within the VM itself.
    Refer : https://learn.microsoft.com/en-us/azure/virtual-network/virtual-network-network-interface#change-dns-servers

    Kindly let us know if the above helps or you need further assistance on this issue.

    ----------------------------------------------------------------------------------------------------------------

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments