What could I be missing with my Exchange Outbound setup?

Viver Pacan 26 Reputation points
2021-06-19T04:43:48.793+00:00

Issue: Outgoing emails are not sending

It all started when we where blacklisted with UCEPROTECTL3, which was ISP's fault and not ours and fixed after a few days, and got notified that they will be blocking port 25 due to spam issues. Now they are pushing us to use ports 587 and 2525.

Now, I will be using 587 instead of 25 and here are my changes:

-Firewall port forwarding changed to 587
-Default Frontend Mail from Receive Connector port changed to 587
-Send Connector port changed to 587 (Using MX record and no smart host)
-Exchange server firewall turned off (temporarily)
-AV also turned off (temporarily)

Tests done:

Mxtoolbox Blacklisted Test 0 listing
Microsoft test connectivity - Outbound Test Success
Wormly SMTP Test Inbound via 587 Success
Telnet on smtp.mail.yahoo.com and smtp.gmail.com via 587 Connects

With all these configuration and tests, we still can't send outgoing. Everything is stuck in queue.

What could I be missing here?

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,338 questions
0 comments No comments
{count} votes

Accepted answer
  1. Andy David - MVP 141.2K Reputation points MVP
    2021-06-19T12:59:20.703+00:00

    You can't send mail on port 587 to other servers. They are listening on port 25 for anonymous SMTP connections from other mail servers..

    You can only use a different port if you are sending through an outbound SMTP gateway/ smarthost that is listening on that same different port and then sends the mail on port 25.

    Also, port 587 is the authenticated submittal port for clients. There was no need to make any changes on the Exchange receive connector. Exchange listens on that automatically.
    The reason it works with port 587 for yahoo and gmail is that is the standard client submittal port - but it requires authentication.


1 additional answer

Sort by: Most helpful
  1. Xzsssss 8,861 Reputation points Microsoft Vendor
    2021-06-21T02:36:16.473+00:00

    Hi @Viver Pacan ,

    Actually I don't think blocking port 25 is a wise choice, as the mail flow uses it for routing.
    Network ports required for mail flow (no Edge Transport servers)

    You may have to use a Smart Host to redirect the mail flow outside from your server. Or you should open port 25 for the transporting.

    Best regards,
    Lou


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.