i can not connect to my VM over RDP

KTELLAWI 1 Reputation point
2021-06-19T20:15:17.737+00:00

hello
i couldn't connect to VM by RDP and below wrong messages is appearing to me when i try to connect

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,060 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. Andreas Baumgarten 94,711 Reputation points MVP
    2021-06-19T21:29:16.893+00:00

    Hi @KTELLAWI ,

    in most cases a NSG is missing a Security Rule to allow "inbound TCP Port 3389":
    https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/troubleshoot-rdp-nsg-problem

    NSGs can be associated with the VM and/or subnet. Both NSGs require the Security Rule.
    https://learn.microsoft.com/en-us/azure/virtual-network/network-security-group-how-it-works

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten

    0 comments No comments

  2. KTELLAWI 1 Reputation point
    2021-06-19T21:40:22.907+00:00

    hello @Andreas Baumgarten

    there is no NSG rule missing please look at the image below :

    107170-nsg.jpg

    0 comments No comments

  3. Andreas Baumgarten 94,711 Reputation points MVP
    2021-06-19T23:17:05.167+00:00

    Hi @

    please try the Connection troubleshoot for the VM:

    107189-image.png

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten

    0 comments No comments

  4. KTELLAWI 1 Reputation point
    2021-06-20T09:07:26.853+00:00

    I did it but unfortunately, it was not succeed
    I still unable to connect over RDP
    may the problem in extension affects on connection
    please check the image below

    0 comments No comments

  5. Andreas Baumgarten 94,711 Reputation points MVP
    2021-06-20T09:26:52.77+00:00

    Hi @KTELLAWI .

    there is a NSG blocking the incoming network traffic because there is a missing Security Rule for allow incoming TCP 3389.

    Do you have specified the Source Port in the NSGs? If so please choose any for the Source Port. Only the Destination Port needs to be specified with 3389

    Please check the network settings of your VM again:

    Here you can see two NSG affecting the VM01 (one associated with the VM one with the related subnet) - Click on Effective security rules

    107257-image.png

    Here are the Effective security rules for the NSG associated with the VM

    107297-image.png

    Here are the Effective security rules for the NSG associated with the subnet related to the VM

    107331-image.png

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten

    0 comments No comments