No Subscription

Lhen Villa 6 Reputation points
2020-07-09T02:04:58.67+00:00

I have 2 accounts; a personal and work account. When I login to any of my account, there are instances when the subscriptions showing are those that are connected to my work account while there are instances when the subscriptions showing are those that are connected to my personal account. It's always one way or the other. No matter how I switch directory or to another account, one would always show "No Subscription". What can I do so I can access the correct subscription based on the account that I am currently logged in?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,534 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Lhen Villa 6 Reputation points
    2020-07-09T02:27:03.657+00:00

    Sorry, but my question is not about office but azure accounts. To be more specific, when I login to the Azure Portal (portal.azure.com) using my work account, there are instances when it is showing "No subscription" when I am assigned as "Owner" and "Co-owner" to multiple subscriptions in our organization. The same thing happen when I login using my personal account, where I am set as "owner" and "co-owner" to some paid accounts.

    Example:
    work account -> work.email.com
    -> associated subscriptions: wrksubscription1, wrksubscriptiion2
    personal account -> personal.email.com
    -> associated subscriptions: pnlsubscription1, pnlsubscriptiion2

    Scenario 1:

    1. Launch portal.azure.com
    2. Login using work.email.com
    3. Available Directory/Subscription are shown
    4. Select a directory from Switch Directory panel
    5. Result: No Subscription notification
    6. Login to another account, personal.email.com
    7. Available Directory/Subscription are shown
    8. Result: Subscription/Directory successfully loaded. I can assess the subscription.

    Scenario 2:

    1. Launch portal.azure.com
    2. Login using work.email.com
    3. Available Directory/Subscription are shown
    4. Select a directory from Switch Directory panel
    5. Result: Subscription/Directory successfully loaded. I can assess the subscription.
    6. Login to another account, personal.email.com
    7. Available Directory/Subscription are shown
    8. Result: No Subscription notification
    1 person found this answer helpful.
    0 comments No comments

  2. Anonymous
    2020-07-09T02:06:19.677+00:00

    Office is not currently supported here on QnA. They're actively answering questions in dedicated forums here.
    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_account
    https://social.technet.microsoft.com/Forums/en-US/home?category=officeitpro

    --please don't forget to Accept as answer if the reply is helpful--


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    0 comments No comments

  3. Anonymous
    2020-07-09T02:30:57.567+00:00

    If you think its an Azure problem you can submit a ticket here.
    https://azure.microsoft.com/en-us/support/create-ticket/

    if you think its a microsoft account problem you can chat with account support here. Try using the Open Get Help app here, and you'll eventually get to chat with microsoft account support.
    https://support.microsoft.com/en-us/contactus/

    --please don't forget to Accept as answer if the reply is helpful--


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    0 comments No comments

  4. Lhen Villa 6 Reputation points
    2020-07-09T02:33:30.717+00:00

    I actually tried to enter a support ticket already but since I am getting a "No Subscription" notification at the moment, I received a notification that I am not authorized to send a request.


  5. Lhen Villa 6 Reputation points
    2020-07-09T05:13:27.233+00:00

    Tried those already and I got the same result. Interestingly though, I used the Open Get Help app until I was prompted to visit the Azure support site. When I clicked the Go There Now link and logged in, the expected subscriptions showed up.

    11548-azure.png

    But when I closed the page, launched azure.portal.com and logged in as usual, "No subscription" notification shows up.