404.11 from URL part !2fo%3a92c8dd8d-1ae6-40e7-9347-f2d4f728eeea

Troy Hughes 1 Reputation point
2021-06-21T22:34:35.16+00:00

I read up on the possible causes of 404.11 and from what I can tell I'm not using any of the possible special characters that would cause a 404.11. Can someone enlighten me on why the !2fo%3a92c8dd8d-1ae6-40e7-9347-f2d4f728eeea portion of this URL is invalid?

https://localhost:44350/roles/!2fo%3a92c8dd8d-1ae6-40e7-9347-f2d4f728eeea/Test%20Role

I know that the following works.

https://localhost:44350/roles/!2f/Test%20Role

However adding the following to that URL part seems to trigger the 404.11.

o%3a92c8dd8d-1ae6-40e7-9347-f2d4f728eeea

Please note I'm using the version of IIS Express that comes with Visual Studio 2019 v16.10.1

ASP.NET Core
ASP.NET Core
A set of technologies in the .NET Framework for building web applications and XML web services.
4,375 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Sam Wu-MSFT 7,286 Reputation points Microsoft Vendor
    2021-06-22T02:47:57.53+00:00

    @Troy Hughes

    The error indicates that the Webserver is having a problem with the presented URI, double Escaped characters in the URL, which are a standard currently for URL's are blocked by the Webserver.

    To resolve this issue, the Request Filtering Module need to either disabled, or configured to allow and pass through in the URI request the double escaped characters.

    You can set the allowDoubleEscaping attribute in applicationHost.config. %windir%\System32\inetsrv\config\applicationHost.config

    <system.webServer>  
        <security>  
            <requestFiltering allowDoubleEscaping="true"/>  
        </security>  
    </system.webServer>  
    

    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments