PXE - one machine unable to proceed past "NBP file downloaded successfully", other machines all fine

macarotto 96 Reputation points
2021-06-22T14:51:09.713+00:00

Hi, we have a small WDS setup using Microsoft Deployment Toolkit (no SCCM/MEM involved), and I'm able to successfully re-image machines usually. I've come across one machine that seems to be unable to proceed beyond downloading the NBP file. The machines are all using UEFI to boot including this one.

The machine boots and I press F12 to network boot, and I see the below

>Checking Media Presence.......
>Media Present........
>Downloading NBP file...
>NBP file downloaded successfully.

This screen remains for approx 5 seconds, then it proceeds to instead try and do PXE over IPv6 instead. This fails (this is expected) and the machine instead boots up to the installed OS.

Looking at the Deployment-Services-Diagnostics logs in Event Viewer I can see the machine appears to be successfully PXE booting and downloading at least one files form TFTP with no signs of errors or failures.

The following client booted from PXE:
Hardware Address: <MAC address of the machine>
IP: 172.16.32.90
Device ID: {1F261432-E23E-6911-841C-1C697A664DC4}
ClientArchitecture: 4
Prestaged: false

A Non-Shared buffer was created for reading file E:\RemoteInstall\boot\x64\wdsmgfw.efi.

The Following Client completed TFTP Download:
Client IP: 172.16.32.90
Filename: boot\x64\wdsmgfw.efi
File Size: 1322528
Client Port: 1393
Server Port: 57112
Variable Window: false

Other machines proceed after this to also download files such as bootmgrfw.efi, boot.sdi, WIM and BCD files, but this one doesn't seem to proceed beyond the initial wdsmgfw.efi download.

I've checked the BIOS settings and UEFI booting is enabled on this machine. I've compared the settings with a working machine and everything appears to be the same. I've also tried imaging this PC using the same cable that worked on another machine in case of a cable fault, with no success.

All the threads I'm finding online about this are referencing situations where all machines are having this problem, rather than just individual machines. I've also checked with my colleagues who are more familiar with it and they're unsure as to what the issue could be either.

Any suggestions on where to look next would be appreciated.

Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
821 questions
Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,899 questions
0 comments No comments
{count} votes

Accepted answer
  1. macarotto 96 Reputation points
    2021-07-06T10:28:21.503+00:00

    Apologies for the delay in replying - the BIOS update suggestion didn't work unfortunately, however this has turned out to simply be an vague UI issue!

    Normally when we PXE-boot devices, it'll give us some sort of prompt e.g. "Press Enter/F12 to Network Boot" after it picks up a DHCP lease and such. In the case of this machine and a few others I've come across with the same issue, once it says "NBP file downloaded successfully", as long as I hit F12 a couple of times it'll bring up the list of boot images as expected.

    Thanks for the suggestions.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Colin Ford 1,026 Reputation points
    2021-06-23T06:04:39.323+00:00

    Do you have other machines of the same model working? If so, try change the BIOS version to match a working machine's version.

    0 comments No comments

  2. AllenLiu-MSFT 39,841 Reputation points Microsoft Vendor
    2021-06-23T07:18:22.47+00:00

    Hi, @macarotto
    Thank you for posting in Microsoft Q&A forum.
    Have you configured any DHCP option? You may try to add WDS ip to the IP Helper to see if it helps.
    For the reference:
    https://community.spiceworks.com/topic/1836566-surface-pro4-stuck-on-start-pxe-over-ipv6
    (Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments