Deploying a flask web app with using azure web app service from github. Requirements.txt is throwing an error

Dhananjay Sharma 1 Reputation point
2021-06-23T10:49:49.293+00:00

The requirements.txt file has 'numpy' yet when it comes to 'pybf' i get the "no module named numpy" error. I even tried installing numpy separately in the yaml file. Still it won't work! I've tried a variety of methods but my deployment keeps on failing!

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,847 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Ryan Hill 25,481 Reputation points Microsoft Employee
    2021-07-07T22:53:54.553+00:00

    Hi @Dhananjay Sharma , sorry for the delayed response. When I tried setting up a local environment, I ran into the same error on that you encountered on your build pipeline. This occurred against all major versions of the library, 0.2.2 to 0.2.5. I'm using pip 21.1.3 against Python 3.7.8. The issue isn't with your GitHub action. Checking pypi.org only shows 0.2.5. Since this hasn't been updated 5 years and the author has stated moving on from python, I would advise finding a library that's better supported.