Azure App Service Linux Web App: It was not possible to find any installed .NET Core SDKs

Robson Rocha de Araújo 1 Reputation point
2021-06-24T02:34:59.003+00:00

I'm trying to publish my .NET Core 3.1 ASP.NET app to an App Service Linux (code deploy, not containerized app), and it does not start.

Getting the container logs from Kudu, I'm getting the following:

021-06-24T02:22:42.304076643Z   _____                               
2021-06-24T02:22:42.304110643Z   /  _  \ __________ _________   ____  
2021-06-24T02:22:42.304117143Z  /  /_\  \___   /  |  \_  __ \_/ __ \ 
2021-06-24T02:22:42.304121343Z /    |    \/    /|  |  /|  | \/\  ___/ 
2021-06-24T02:22:42.304125143Z \____|__  /_____ \____/ |__|    \___  >
2021-06-24T02:22:42.304129143Z         \/      \/                  \/ 
2021-06-24T02:22:42.304132843Z A P P   S E R V I C E   O N   L I N U X
2021-06-24T02:22:42.304136443Z 
2021-06-24T02:22:42.304139944Z Documentation: http://aka.ms/webapp-linux
2021-06-24T02:22:42.304143344Z Dotnet quickstart: https://aka.ms/dotnet-qs
2021-06-24T02:22:42.304146944Z ASP .NETCore Version: 3.1.13
2021-06-24T02:22:42.304150444Z Note: Any data outside '/home' is not persisted
2021-06-24T02:22:42.756840176Z Running oryx create-script -appPath /home/site/wwwroot -output /opt/startup/startup.sh -defaultAppFilePath /defaulthome/hostingstart/hostingstart.dll     -bindPort 8080 -userStartupCommand 'dotnet ProCoding.PortalAluno.dll' 
2021-06-24T02:22:42.951071377Z Cound not find build manifest file at '/home/site/wwwroot/oryx-manifest.toml'
2021-06-24T02:22:42.951101677Z Could not find operation ID in manifest. Generating an operation id...
2021-06-24T02:22:42.951108277Z Build Operation ID: 15cbdf0d-63a6-4638-aaa6-8ff5ad6b1408
2021-06-24T02:22:44.862027609Z Writing output script to '/opt/startup/startup.sh'
2021-06-24T02:22:45.080456432Z Running user provided startup command...
2021-06-24T02:22:45.266426538Z   It was not possible to find any installed .NET Core SDKs
2021-06-24T02:22:45.266513339Z   Did you mean to run .NET Core SDK commands? Install a .NET Core SDK from:
2021-06-24T02:22:45.266523739Z       https://aka.ms/dotnet-download

I've already tried publishing using VS2019, VSCode, AzureDevOps, and the result is the same.

I've tried publishing the new Web App to an existing Linux App Service, and to a new Linux App Service, and the result is the same.

And I've also tried to publish a copy of my existing apps to the new web apps, and the result is still the same, which makes me believe that there is something wrong with Azure.

The only thing that I've not tried is to publish the new web app over an existing web app, but redeploying the same apps again using Azure DevOps and Vs2019 works fine.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,766 questions
{count} votes