I cann't install soapcliejnt on wordpress on azure app service

Haze 1 Reputation point
2021-06-30T19:01:03.45+00:00

In WooCommerce -> Status I have message like that "Your server does not have the SoapClient class enabled - some gateway plugins which use SOAP may not work as expected." So I want to install SoapClient on my azure web service.

I try to do it over Azure SSH and bash. I have tried in several ways. I was closest to doing it because it was even installed with this command: pear install SOAP-0.14.0, but after reset server on azure. It still does not work.

110761-image.png

When I perform this action twice I get this message, but when I do a reset I can install it again.
110771-image.png

I also tried with sudo apt-get install php7.3-soap

Results from SSH:
110715-image.png 110743-image.png
Results from BASH:
110716-image.png
110744-image.png

I also tried with yum install php-soap but yum doesn't work on SSH and bash.

Additional information:
110772-image.png
110762-image.png

Would someone be able to tell me what I'm doing wrong? Thank you in advance.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,847 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Grmacjon-MSFT 15,696 Reputation points
    2021-07-02T22:31:40.743+00:00

    Hi @Haze ,

    We are sorry you're facing this issue. Have you tried updating your PHP version (7.4) to the latest version?

    Make sure your PHP version is updated before trying to install an extension. To update the PHP version, Go to your app in the Azure portal and click on the Settings button. From the Settings blade, select Application Settings and choose the new PHP version.Click the Save button at the top of the Application settings blade. This can also be done through CLI and powershell as shown in this documentation.

    Also, you can double-check to see if you already have SOAP installed by using this command: php -i | grep -i soap. If it is not installed, trying using this command sudo apt-get install php7.4-soap and then restart your server. You can also see this related Stack Overflow thread.

    Hope that helps. Please let us know if you have further questions
    -Grace

    0 comments No comments