ADF Linked Service to Azure Blob (using SAS token) Successful, but Cant browse or read containers/blobs

Vinodh 6 Reputation points
2021-07-01T15:46:33.91+00:00

In ADF, I successfully created a linked service to the Blob storage using a SAS token (Test Connection succeeds). But, when I browse the container/files in the dataset, I get a 'Blob operation Failed. ContainerName: , path: . The remote server returned an error: (404) Not Found.StorageExtendedMessage=The specified resource does not exist' error. I even tried to access the Blob dataset using Lookup, GetMetadata tasks, but got same error everywhere.

I have verified that the SAS token has these parameters -> &ss=bt and &srt=sco and &sp=rl and the dates are valid too. I am able to connect to the Blob storage using Az Storage Explorer, access the container and its files.

Not sure what I'm missing in ADF. I would be thankful & appreciate any immediate help.

111027-adf-blob-sas-token-error.png

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,492 questions
Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,762 questions
{count} vote

1 answer

Sort by: Most helpful
  1. ASHUTOSH P. NAGAONKAR 1 Reputation point
    2021-10-01T10:20:09.02+00:00

    Hi,

    To make directory visible after clicking browse, try using SAS URL of the storage account and not of the specific file.

    0 comments No comments