Getting "Your organisation requires more information" With Security defaults disabled, No conditional access policy, No SSPR and the user displaying as disabled in ad

Aegis Office 365 Admin 21 Reputation points
2021-07-02T14:09:06.493+00:00

We recently started an azure trial

So since the 30th new users who are created are asked for mfa details when signing into only dekstop office apps for the first time.

Even though SSPR is disabled, there are no condiditional policies and they display as disabled on mfa list on 365.

However if they login through office online they don't get the prompt.

The prompt they are getting is "Your organisation needs more details"

This is an issue as users dont have work mobiles

111318-image.png

However noticed that on the screen before which says stay signed in to all your apps if you press sign into this app only the prompt also doesnt appear

111374-image.png

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,916 questions
0 comments No comments
{count} votes

Accepted answer
  1. Vasil Michev 97,306 Reputation points MVP
    2021-07-02T18:31:57.03+00:00

    There are few other places where registration might be required, for example Azure AD Identity Protection driven MFA registration. Or the old-style per-user MFA controls. Or the Device join experience shown on your second screenshot, which in the default configuration will require the user to perform MFA.
    Go to the Azure AD blade > Devices > Device settings > and toggle the "Require Multi-Factor Authentication to register or join devices with Azure AD" setting.
    Although that should be done just to confirm that this setting is triggering the behavior you're observing. In this day and age, MFA is strongly recommended. Users can use personal mobile phones or if you're not allowed to use phones altogether, look into passwordless methods such as FIDO.

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful