Question regarding an error I am seeing when attempting to clone a vm

Nathan whitehead 21 Reputation points
2021-07-02T17:40:15.157+00:00

Hey Everybody,

I have done a fair bit of research and I can't seem to find an answer specifically for my issue.

I am attempting to clone a vm in the vmm fabric and I am receiving the error:

Error (12700)
VMM cannot complete the host operation on the (XXXX) host server because of the error: Import Failed. Import task failed to copy the file from (New VM file location) to the host. They System cannot find the specified file.

Recommended Action
Resolve the host issue and then try the operation again.

Specs:

Windows 2012 server
This vm I am attempting to clone is in a cluster

I have verified the "allow migration to a vm host with a different processor version" is selected.

I have tried to clone the vm to different hosts within the same cluster and I'm receiving the same error.

Any ideas would be appriciated!

Let me know if you need anymore information.

System Center Virtual Machine Manager
{count} votes

Accepted answer
  1. XinGuo-MSFT 13,931 Reputation points
    2021-07-08T09:08:03.93+00:00

    Based on my research, the .vmgs file is used for version 8.2 or higher Hyper-V virtual machines and is used to store the virtual machine guest state.

    All the .vmgs files are fixed size 4,194,816 bytes and contain some JSON information.

    We don’t know why this file is missing. We can try to manually copy this file and rename it to see if the problem can be solved.

    Or

    We will see VMCX, VMRS, and VMGS binary files in the Snapshots folder after create a Checkpoint.
    https://adamtheautomator.com/export-vm/

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Nathan whitehead 21 Reputation points
    2021-07-06T16:19:39.38+00:00

    @XinGuo-MSFT Thanks for your quick reply!

    I am an Admin on the VMM server and I do have write permissions to that target file location.

    The event logs in Applications and Services Logs -> Microsoft -> Windows -> Hyper-V-VMMS - show the same error message stated above:

    Import failed. Import task failed to copy file from '\XXXXX\XXX\XX\Virtual Machines\3C34A046-F002-4D3A-8D93-083EB040798C.vmgs' to 'C:\ProgramData\Microsoft\Windows\Hyper-V\Planned Virtual Machines\61FF2EE6-6293-4846-BAB6-87BAE456E1F1.vmgs': The system cannot find the file specified. (0x80070002).

    There are no logs in the Applications and Services Logs -> Microsoft -> Windows ->Hyper-V-Worker location.

    Do you have any other ideas?