Resource group has a hidden service endpoint policy, not able to delete it

Qi-Jian-Huang-DevOps 166 Reputation points
2021-07-06T05:37:49.787+00:00

I have a resource group which deployed sql managed instances in it before, now everything inside the resource group is deleted except this hidden service endpoint policy '_e41f87a2_mi_e1bc2ccc-26d4-4e34-9d0a-ada1a1563171'

when I tried to delete it, it got following errors:

Failed to remove the service endpoint policy '_e41f87a2_mi_e1bc2ccc-26d4-4e34-9d0a-ada1a1563171'. Error: Client c44b4083-3bb0-49c1-b47d-974e53cbdf3c if not authorized to access service endpoint policy rg-network-apk/providers/Microsoft.Network/serviceEndpointPolicies/_e41f87a2_mi_e1bc2ccc-26d4-4e34-9d0a-ada1a1563171.

And when I tried to delete the resource group, it complains about the

Failed to delete resource group rg-network-apk: Deletion of resource group 'rg-network-apk' failed as '7' resources could not be deleted.
(Code: ResourceGroupDeletionBlocked) Network security group/rg-network-apk/providers/Microsoft.Network/networkSecurityGroups/nsg-snet-frontend-apk-001 cannot be deleted because it is in use by the following resources resourceGroups/rg-network-apk/providers/Microsoft.Network/virtualNetworks/vnet-apk-001/subnets/snet-frontend-apk-001

But the resources nsg-snet-frontend-apk-001 and snet-frontend-apk-001 are both deleted already, and can't see them in the resource group.

some guidance would be helpful, thanks.

Azure DevTest Labs
Azure DevTest Labs
An Azure service that is used for provisioning development and test environments.
261 questions
0 comments No comments
{count} votes

Accepted answer
  1. kobulloc-MSFT 25,151 Reputation points Microsoft Employee
    2021-07-06T07:21:52.383+00:00

    Thank you for bringing this to our attention! Although rare, resources can sometimes end up in a stuck state and we need to delete them from our end. I'll reach out to you privately to resolve this.


0 additional answers

Sort by: Most helpful