Job Deploy: Environment test-ode could not be found. The environment does not exist or has not been authorized for use.

Jayashree Bose 21 Reputation points
2021-07-06T07:19:03.337+00:00

Hi,
We have an pipeline which is being used to provision our resources. This pipeline uses a deployment job. Earlier, if the Environment does not exist, pipeline used to create the environment automatically which is not happening due to the recent changes in Azure DevOps as mentioned in the documentation https://learn.microsoft.com/en-us/azure/devops/release-notes/2021/sprint-188-update#changes-in-the-automatic-creation-of-environments .
So, when I am trying to run the pipeline without the environment, I am getting the below error:

112026-image.png

I have tried to create the environment using powershell script (which is using APIs to create the environment) within pipeline, but still getting the same error. I would like to Know, if the older behavior of automatic environment creation can be achieved?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,755 questions
0 comments No comments
{count} votes

Accepted answer
  1. prmanhas-MSFT 17,901 Reputation points Microsoft Employee
    2021-07-06T07:37:42.17+00:00

    @Jayashree Bose Thank you for your query!!!

    Please note that Azure DevOps is currently not supported in the Q&A forums, the supported products are listed over here : https://learn.microsoft.com/en-us/answers/products.

    You may ask the experts in the dedicated Azure DevOps forum over here:

    https://developercommunity.visualstudio.com/report?space=21&entry=problem

    Hope it helps!!!

    Please "Accept as Answer" if it helped so it can help others in community looking for help on similar topics.

    0 comments No comments

0 additional answers

Sort by: Most helpful