Azure Sphere Device Connection Problems

Marcel Ball 26 Reputation points
2021-07-07T06:15:38.9+00:00

Hi, I am having intermittent issues with connection to me Sphere devices.

I started with the Seeed MT3620 mini dev board, followed the the guide to get started and had no problems at all. I claimed the device to my tenant and ran some example code with no problems.

I then switched over to some custom hardware with the MT3620 fitted and a custom programming board based on the FT4232. A device rescan-attached showed 1 attached device but device show-attached says that the device is not responding.

Changing back to the Seed mini dev board, device rescan-attached no longer detects the MT3620. Restarting the PC seems to enable the rescan-attached again with the device being found. After a short period of time the rescan-attached command no longer discovers a device.

I have been through the trouble shooting guide, https://learn.microsoft.com/en-us/azure-sphere/install/troubleshoot-installation but nothing seems to fix the problem.

  • I am powering the RTC by the main 3V3 supply
  • I have tried multiple USB ports, including a powered USB hub
  • No other software is using the subnet 192.168.35.*
  • FTDI drivers are the latest downloaded from https://ftdichip.com/drivers/
  • I have tried restarting the Azure Sphere Device Communication Service
  • The TAP-Windows adapter is installed and configured as expected (There is one TAP Adapter)
  • I have uninstalled and re-installed the Azure SDK. The installed version is 21.04.1.43553
    112407-ports.png
  • I am not using a CISCO AnyConnect VPN
  • The TAP Adapter has been uninstalled and re-installed
  • I have checked the restore.json. When the rescan-attached discovers the device the file contents look like this: [{"location":35734083,"ipAddress":"192.168.35.2"}]. When the rescan-attached fails the json is an empty array: []
  • I deleted the json and restarted the Azure Sphere Communication Service with no improvement
  • There have recently been some Security Update for Microsoft Defender Antivirus.
Azure Sphere
Azure Sphere
An Azure internet of things security solution including hardware, operating system, and cloud components.
156 questions
{count} votes

Accepted answer
  1. dafang982 81 Reputation points
    2021-07-09T09:24:54.983+00:00

    FTDI has confirmed there are issues with their latest driver and they are working on a fix for it. Please use the previous 2.12.28 driver instead.

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful