Exchance 2016 transport rule doesn't apply if forwarding enabled in a user's mail flow

Overworked Sysadmin 11 Reputation points
2021-07-09T19:53:47.273+00:00

HI,

I've setup a transport rule to bounce back emails for emails in a specific DL. See below:

113463-exemployee.png

However, the rule does not work if there's a mail flow forwarding enabled for that account. See below:

113420-mailflow.png

If I disable the forwarding rule, the transport rule works as expected.

I did my research but could only find reports of issues if there's a forward rule in the user's outlook but the behavior isn't the same here (and its set to match address on header or enveloppe already anyways).

Is there something I can do to make this work? We need the forwarding rule for internal users and some automated stuff with hardcoded emails (I know that's bad, but beyond me).

Thanks.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,330 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Overworked Sysadmin 11 Reputation points
    2021-07-16T12:43:55.09+00:00

    Nan, too much trouble and poorly manageable.
    I setup some rule in CodeTwo instead of the transport rule. That works fine.

    1 person found this answer helpful.

  2. Andy David - MVP 140.8K Reputation points MVP
    2021-07-09T20:10:31.827+00:00

    Can you make the forwarding rule a transport rule instead and have it a lower priority after the "Reject" rule?
    You could also make the criteria in the forwarding rule to only fire if the sender is internal.

    0 comments No comments

  3. Overworked Sysadmin 11 Reputation points
    2021-07-09T20:22:42.24+00:00

    I could of course, but that would require a distinct transport rule for each mailbox that requires forwarding if the destination isn't the same! And most are different destinations, depending on department or purpose of email.

    I did also look into enforcing authentication of sender so external senders are rejected but that causes trouble for internal addresses with no mailboxes (think camera, printers, etc). We are working on making all emails sent internally to authenticate but I'm sure you are aware this is no trivial task.

    0 comments No comments

  4. Andy David - MVP 140.8K Reputation points MVP
    2021-07-09T21:02:44.963+00:00

    Gotcha! There is another option if you want to treat all these internal processes as "authenticated".
    Create a new receive connector and for the remote addresses, scope it to the IPs of those devices.
    Then set the auth on this new receive connector to "Externally Secure". that will effectively treat any devices that sends through that connector as authenticated and internal.
    https://learn.microsoft.com/en-us/exchange/mail-flow/connectors/allow-anonymous-relay?view=exchserver-2019

    113390-image.png


  5. Xzsssss 8,861 Reputation points Microsoft Vendor
    2021-07-12T02:47:34.077+00:00

    Hi @Overworked Sysadmin ,

    The second screenshot, is it a user mailbox? Because as I know there are no such options for mail users and mail contacts. Then the question is whether this user is inside your organization or from another Exchange server?

    And also you could create the forward transport rule(even the sender is from external as below) as Andy said,
    113648-image.png
    And make it a lower priority.
    113608-image.png

    I'm a bit confused about the screenshots your provided, if I'm wrong, please fix me:)

    Best regards,
    Lou


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.