User or password did not work, rdp app on ios, one specific user

paulb 96 Reputation points
2021-07-11T10:17:16.09+00:00

Very strange situation, trying to access a server 2012 domain user’s win 10 pc remotely I found it would not accept his login credentials when I tried to connect from my iPad using either the MS rdp app OR TeamViewer. It is the Windows login on his pc that fails with “password is invalid” (via TeamViewer) or “the user account or password did not work” (rdp app.) I am however able to log in to this pc, through either app, using the domain admin account (as well as other users’ pc’s with their accounts.) And, I am able to log in to his account using either method from my remote PC. . . He had some issues with windows update/corrupted system store that I thought might be related, but trying a couple of other on-site pc’s that he should have access to I get the same results, so it seems to be related to his account rather than his pc. I have looked into NLA, and I remember a couple years ago the iOS rdp app had some authentication issues, but the set of circumstances seems to rule those things out. How could it just be this user, only from iOS?? Something with the iOS keyboard not correctly transmitting his password?? I have of course checked, rechecked, copied & pasted, saved, shown when entering it etc. . .

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,231 questions
0 comments No comments
{count} votes

Accepted answer
  1. paulb 96 Reputation points
    2021-07-11T10:58:14.477+00:00

    Well I have stumbled on the solution, after a week of pulling my hair out. . Indeed it has to do with the iPad keyboard substituting punctuation marks via "smart punctuation" whatever that is.. it was messing with that user's password. Disabled it in settings and it works. Must have been a change with an update or something as I didn't used to have the problem, and obviously it doesn't always do it since I was able to log in on the remote web site. Maybe it has to do with recognizing different types of text entry fields or something.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. paulb 96 Reputation points
    2021-07-11T10:37:24.863+00:00

    Oh, I AM able to log in to the remote website (running WSE experience on the server. . ) and so I just tried going to his desktop via the Devices link on that, which downloads an .rdp file which then opens in the rdp app - and this works! I don’t see a way to edit the rdp file on my iPad though, so not sure what is different about it (I have a bunch of other saved desktop connections in the app that all work fine, same RD gateway etc. . .)

    Still no luck in TeamViewer though. One clue maybe, when I type his password, the last two characters are “shift” characters, so I switch to the alternate keyboard for those. After the first of them, it stays in this mode. But after the second one, it switches back to the alphabet mode. Kind of odd… If I press on the “eye” icon, the password is correct - but maybe there is something about it that isn’t showing up? Probably a question for TeamViewer, unfortunately their support & community sites are coming up blank for me, on all browsers & platforms (I think they recently changed to “fresh desk” for this stuff, which I don’t have high hopes for.)