SharePoint Anyone link cannot be enabled

Beran Karel 21 Reputation points


Even though Anyone link is enabled in the SharePoint Administrative Center - Sharing and Active Sites, it still doesn't work. The Anyone link option is not active (grayed out) and still shows a message that your organization is blocking this option.

Do I need to set up above the SharePoint level? In Microsoft 365 or Azure?

Thank you for the advice.

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,790 questions
0 comments No comments
{count} votes

Accepted answer
  1. CaseyYang-MSFT 10,316 Reputation points

    Hi @Beran Karel ,

    1.Please check you Sharing and Active Sites setting again. Make sure you have sharing settings enabled properly.

    2.This issue may also occur if the site collection feature Limited-access user permission lockdown mode is activated. You could try to deactivate Limited-access user permission lockdown mode feature.
    Settings > Site Information > View all site settings > Site collection features > Limited-access user permission lockdown

    3.You could try to use PowerShell code to set SharingCapability.
    PowerShell code:

    Set-SPOSite -Identity your site url -SharingCapability ExternalUserAndGuestSharing  

    For Reference:

    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Beran Karel 21 Reputation points

    Hi, thank you for your response.
    I've already tried and checked all this (except PowerShell). After activating / deactivating the Limited-access user permission lockdown, I have achieved that Any link works for me for open channels, but still not for private channels.