Error 0x704 for Remote Desktop on Mac

Kortas 1 Reputation point
2021-07-13T18:04:31.287+00:00

Hi,

I am having trouble with the Microsoft Remote Desktop app, it wont act normal for some reason. I am launching a server on AWS and I have everything perfect up until it actually opening...initially i got error 0x204 but I turned my firewall off and it worked, then i closed it and tried opening it again and now I am getting error 0x704. I have no idea what to do except ask here because I was referred through the main microsoft form to ask here. Please HELP!!!

Thanks!

P.S - Everything is updated, the app, my computer etc is all updated.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,234 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Andy YOU 3,066 Reputation points
    2021-07-14T08:15:44.997+00:00

    1.0x704 means The specified port is unknown.
    In general, we need to open 3389 RDP port in windows firewall on AWS server.

    2.If we install Microsoft Remote Desktop Beta for Version 10.6.8 (1898) on Mac computer, will the same issue happen?
    Microsoft Remote Desktop Beta for Version 10.6.8 (1898)
    https://install.appcenter.ms/orgs/rdmacios-k2vy/apps/microsoft-remote-desktop-for-mac/distribution_groups/all-users-of-microsoft-remote-desktop-for-mac

    ============================================
    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments