Disabling Hyper-V on windows 11

Vraj Mistry 51 Reputation points


I just installed windows 11, and for some reason there is a hyper-v detected which is preventing me from running some programs. Unfortunately, the process to disable it is different from windows 10 and doesn't work for windows 11. Does anyone know how to disable hyper-v?

I reached out to microsoft for support, and they basically denied help, bc they aren't trained to use it yet....


A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,522 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,061 questions
{count} votes

8 answers

Sort by: Most helpful
  1. Georg Schmidt 31 Reputation points

    The same problem is also blocking me.

    The problem is present on all "Windows Surface 7 Pro +" computers which come with Windows 11 pre-installed.

    The fact that hyper-v is detected makes it impossible for me to use some programs.

    I have not found any way to disable Hyper-V.
    Hyper-V is un-checked in Windows Features, and Virtual Platforms are also unchecked / inactive.
    Still msinfo32.exe reports that "Hyper V is detected".

    I am unable to disable Hyper-V.
    The problem is that other programs check if Hyper-V is enabled or not, and they only work if it is NOT enabled.

    I have also tried to activate / install Hyper-V and Virtual Platforms, and then disable them again, but that didn't change anything.
    The suggestions on how to disable Hyper-V on Windows 10 do not work in this case.



    6 people found this answer helpful.

  2. Roman Rokon 21 Reputation points

    As @RammHase and others said that,
    "Hyper-V is not activated in Windows Features, and msinfo32.exe and other apps still shows "Hypervisor or Hyper-V detected", the problem is Windows Defender use a/some virtualization-based secuirity that makes Hyper-V run/enable silently. You have to disable Memory integrity in Windows Secuirity > Device Secuirity > Core isolation. It worked for me.

    Pardon my poor english!

    4 people found this answer helpful.

  3. Iman 16 Reputation points

    @Vraj Mistry I encountered a similar issue when trying to install Intel HAXM. My hyper-v was inactive looking at the windows features, yet system info showed "a hypervisor has been detected". The fix was by disabling the Virtual Machine Platform. VM platform was required when I installed wsl. However, even with the VM platform disabled, my ubuntu wsl is still working fine.

    Hope this help.

    3 people found this answer helpful.

  4. JimNelson 16 Reputation points

    I have the same problem.
    I can not uninstall Hyper-V on my new "Windows Surface 7 +" tablet with Windows 11 preinstalled.
    It shows the message "a hypervisor has been detected. features required for hyper-v will not be displayed".
    I have tried any possible solution that I could find on the internet. Nothing worked.

    2 people found this answer helpful.
    0 comments No comments

  5. Jerome Perri 6 Reputation points

    In my app (for handicapped people) I rely on a 3rd party component which requires a special license for virtual machines.
    It checks for "Hypervisor".
    And because of your bug, where msinfo32.exe says that Hypervisor was detected, my app does not work on hundreds of computers.

    The 3rd party component thinks (and it's right because of Hypervisor is detected by API) that it's on a virtual machine, and the license for that is not valid.

    Windows 11 says that Hypervisor is detected, and you give no chance to fix this.

    1 person found this answer helpful.
    0 comments No comments