Does Windows 10 20H2 version supports .NET Framework 4.7 and below?

Manoj Kumar Yellapragada 21 Reputation points
2021-07-14T15:49:36.003+00:00

Hi,

Does Windows 10 20H2 version supports and .NET framework 4.7.1 and 4.6.2?

I see in one of the article that the Native version for 20H2 is 4.8. does it means other frame works will not work with 20H2 version?

Thanks
Manoj

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,756 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,279 questions
0 comments No comments
{count} votes

Accepted answer
  1. Castorix31 81,861 Reputation points
    2021-07-14T16:16:36.297+00:00

    From MSDN, at .NET Framework system requirements :

    "Windows 10 October 2020 Update (version 20H2)
    Preinstalled with the OS : .NET Framework 4.8"
    "If the OS comes pre-installed with a particular .NET Framework version, you can't install a previous 4.x version on the same machine."


1 additional answer

Sort by: Most helpful
  1. Miles 1,251 Reputation points
    2021-07-15T06:47:58.633+00:00

    Hi Manoj

    As Castorix31 describes:
    If the OS comes pre-installed with a particular .NET Framework version, you can't install a previous 4.x version on the same machine.

    For more specific information, we could refer to this link:
    https://learn.microsoft.com/en-us/dotnet/framework/get-started/system-requirements

    Also, here is a link about NET official support policy, which may help you make a better understanding .
    https://dotnet.microsoft.com/platform/support/policy#:~:text=Support%20for%20.NET%20Framework%20follows%20the%20Lifecycle%20Policy,supported.%20View%20the%20.NET%20Framework%20support%20policy.%20ASP.NET

    Best Regards