ML64 creates wrong offset's . Or did I just forget something in config or somewhere else

HE 21 Reputation points
2021-07-15T00:32:02.023+00:00

@Anna Xiu-MSFT

I described everything in the attached PDF file.
It would be very nice, if someone can give some feedback.

114794-masm-bug.pdf

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,753 questions
0 comments No comments
{count} votes

Accepted answer
  1. Viorel 113.7K Reputation points
    2021-07-15T02:48:19.447+00:00

    Try the “Release” configuration.

    In case of “Debug”, go to Project Properties, and try setting these options (for “x64” platform):

    • Linker, General, Enable Incremental Linking: NO,
    • Linker, Optimisation, Link Time Code Generation: Use Link Time Code Generation (/LTCG).
    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. HE 21 Reputation points
    2021-07-15T11:20:50.357+00:00

    @Viorel
    Thank you very much, all your suggested solutions work fine

    0 comments No comments