Azure Sphere MT3620 Enable Development mode throws error

HaBo 21 Reputation points
2021-07-15T14:38:59.973+00:00

I had this device working fine for few days, recently I deployed new image and to tried to enable deployment mode but it keeps throwing below error

error: An unexpected problem occurred. Please try again; if the issue persists, please refer to https://aka.ms/AzureSphereSDKHelp/Device and https://aka.ms/azurespheresupport for troubleshooting suggestions and support.

Then I tried

azsphere device recover

Device recovered successfully. Then ran the below command

azsphere device enable-development

error: An unexpected problem occurred. Please try again; if the issue persists, please refer to https://aka.ms/AzureSphereSDKHelp/Device and https://aka.ms/azurespheresupport for troubleshooting suggestions and support.

What could be wrong? Id the device cornuted?

Azure Sphere
Azure Sphere
An Azure internet of things security solution including hardware, operating system, and cloud components.
163 questions
0 comments No comments
{count} votes

Accepted answer
  1. Chandranmsft 856 Reputation points
    2021-07-15T23:15:22.227+00:00

    Hi @HaBo - What is the version of SDK you are running on the PC? command is azsphere show-version.

    Also can you share the azsphere device list-attached command output here?

    If both these commands complete successfully, please share the output of azsphere device enable-development --verbose


0 additional answers

Sort by: Most helpful