CT-6886 avatar image
0 Votes"
CT-6886 asked ElevenYu-MSFT commented

[Bug Report] Hyper-V Server 2019 Command Line Tools access to the Volume Manager API [Repeatable Fault]

I have found a bug in Hyper-V Server 2019. This may exist in Server Core 2019, but I've wasted my entire day on this already and do not care to try.

My Environment

  • Hyper-V Server 2019 hosts, all identical

  • Synology NAS running SMB 3, current DSM 6 release

  • Dynamically Expanding VHDX files on a Synology SMB share - 3TB each. One formatted to ReFS, the other to NTFS

  • A script is designed to mount the VHDX and Windows Server Backup operations occur on the VHDX

Went to run a one-off backup this morning to the ReFS disk and it wouldn't run. "ERROR - The specified backup location could not be found or is not a supported backup storage location."

Tried to create a NTFS formatted VHDX (assuming it was a ReFS issue) on the HV system, the hypervisors could create the VHDX, could online it, initialise it and create the partition, but could not format it.

Created the VHDX off-machine, moved it over, attempted the backup and it failed with the same error.

Fully patched the HV install to 2021-07, same error

Ran diskpart list disk - OK
Ran diskpart list partition - OK
Ran diskpart list volume - drive mount point (B:) not shown, volume missing

Go to cmd, can browse and search B:\ fine
Go to PowerShell can browser and search B:\ fine

Use Get-Disk, Get-Partition and Get-Volume in PowerShell - All OK, B drive is displayed as expected in PowerShell's WMI calls

Ran wbadmin get disks which can see the disk but gives:

Volumes: There are no volumes on the disk or Windows is unable to retrieve volume information.

Arduously De-installed the following KB's, rebooting after each

  1. 5003258

  2. 4494174

  3. 4601558

  4. 4589208

  5. 4580422

  6. 5003646

  7. 5003171

  8. 5001342

It all worked again after the removal of "2021-04 Cumulative Update for Windows Server 2019 for x64-based Systems (KB5001342)"

Installed "2021-03 Cumulative Update for Windows Server 2019 for x64-based Systems (KB5001638)" - all fine

Installed "2021-04 Cumulative Update Preview for Windows Server 2019 for x64-based Systems (KB5001384)" - broken again.

Roll back to 2021-03, all fine again.

It appears that something got into the 2021-04 branch and made it into production which has broken the API for reading the disk information. It is doing this on all of my Hyper-V Server 2019 installs. All of the installs work when rolled back to 2021-03.

All Windows Server 2019 GUI instances that I have are not exhibiting this issue.

A full and more comprehensive write-up can be found at:

Anyone else seen this?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ElevenYu-MSFT avatar image
0 Votes"
ElevenYu-MSFT answered ElevenYu-MSFT commented


Thank you for reporting bug to Q&A forum.

Actually, we have received some users' threads to report similar issues as you.

The issue occurs when attempting the backups to a Synology NAS device. At the moment, the workarounds can be summarized as below:

  1. Backup to a windows-based network share.

  2. Uninstalling KB5001347 if installed

  3. Seek for assistance from support engineers of Synology

Also, we suggest that you could report the issue to Feedback Hub and contact Microsoft Customer Support and Services where more in-depth investigation can be done so that you could confirm with the developing team whether it is a bug and if there will be any fix for it.

You may find phone number for your region accordingly from the link below:
Global Customer Service phone numbers

Similar threads for your reference:


If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi ElevenYu-MSFT

Thank-you. I have reported that to Feedback Hum via:

Thanks also for the references. I will have a read!

0 Votes 0 ·


Thank you for reply.

It will be much appreciated and encouraged if you could click "Accept Answer" and upvote it, so that other users who face the same issue can find related information quickly in our Q&A forum.


0 Votes 0 ·

Hi once again ElevenYu-MSFT

I have had a skim through the two links that you mentioned as being similar. I am not entirely convinced that they are the same issue. Similar though!

My issue does not occur under Windows Server 2019 GUI (patched to 2021-07) even though the VHDX's are on the exact same SMB share on the exact same Synology NAS! (I've just re-run a backup on Server GUI to triple check this). Hyper-V Server 2019 though only works if I strip it back to 2021-03.

I am not seeing 0x8078004F in the Application logs. What I am seeing is:

Event ID 12348
Volume Shadow Copy Service warning: VSS was denied access to the root of volume \\?\Volume{snip}. Denying administrators from accessing volume roots can cause many unexpected failures, and will prevent VSS from functioning properly. Check security on the volume, and try the operation again.

Removing auto-release shadow copies
Loading provider
Query diff area for this volume

Execution Context: System Provider


Event ID: 8193 / 0x8000FFFF
Volume Shadow Copy Service error: Unexpected error calling routine Error calling CreateFile on volume '\\?\Volume{snip}\'. hr = 0x8000ffff, Catastrophic failure

Query diff area for this volume

Volume Name: \\?\Volume{snip}\

Finally, it doesn't explain why the newer PowerShell WMI API is working while the legacy API is not working for the same logical operation.


0 Votes 0 ·


Thanks for your further detailed clarification.

In such scenario, you could raise a ticket to report the bug issue by contacting the Microsoft Customer Support and Services as I have mentioned.

Also, welcome to share the resolution to the Q&A forum if you get any feedback after reporting the bug, so that other users who face the same issue could quickly find related information in our forum.

Thank you again.

0 Votes 0 ·