Quick Edit feature of new Document Library UI

Anonymous
2016-08-05T16:39:54+00:00

We just started using the new user interface for documents & folders in SharePoint.   It seems to use frames now to display the file list.  So far I like everything I see except when I use the "Quick Edit" option.  Is anyone else seeing the following behavior?

I have tried this with IE11 as well as Chrome, same results.

  • Click on the "Quick Edit" button
  • Click on the Edit icon  for a document
  • The window frame that shows the document list now shows the edit info but it loads the ENTIRE page within the frame.  So now you are seeing your navigation WITHIN your navigation, your header WITHIN your header, etc.

This makes the screen very difficult to use, below is a screenshot to show the problem.  Is this a known bug?

Microsoft 365 and Office | SharePoint | For business | Windows

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
{count} vote
Answer accepted by question author
  1. Anonymous
    2016-08-23T02:33:44+00:00

    Hi Kristy,

    We have received updates from our escalation team that the issue has been resolved. Therefore, we’d like to share a summary here.

    Description:

    After clicking Quick Edit button in a library, the Edit button in the Edit (link to edit item) column will show. However, clicking on it gets no response.

    Cause:

    Quick Edit feature is not available in SharePoint new experience. For details, please refer to this article.

    Workaround:

    Switch to classic experience and use Quick Edit feature.

    Regards,

    Ryan

    0 comments No comments

7 additional answers

Sort by: Most helpful
  1. Anonymous
    2016-08-05T20:26:30+00:00

    Hi Kristy,

    Could you please try to create a new library to see if the issue persists?

    If yes, I’d like to confirm the following information for further investigation.

    1. Please share a screenshot about the Edit icon for a document with us.
    2. Do all the users in your organization encounter the same issue?

    Thanks,

    Ran

    0 comments No comments
  2. Anonymous
    2016-08-09T10:49:37+00:00

    Hi Kristy,

    We haven't heard from you for a while. Could you let us know any updates at your convenience so we can provide any further assistance that is required?

    Thanks,

    Kerwin

    0 comments No comments
  3. Anonymous
    2016-08-09T12:11:14+00:00

    I was clicking on an edit icon last week that brought me directly to the screenshot I attached before, this week that icon is no longer displaying in the column (See below).  So I suppose in that sense the issue has been resolved.

    Two questions - 

    1. Is the quick edit button supposed to work with the default All Items view?
    2. Is the quick edit button supposed to work with a grouped view?

    0 comments No comments
  4. Anonymous
    2016-08-10T14:19:17+00:00

    Hi Kristy,

    Thanks for your details.

    For the Edit icon, we can just click it directly to edit the item in the old interface of SharePoint library. If we click the quick edit option first, and then click the Edit icon, it will not work. However, regarding the new look for SharePoint library, currently, no matter whether we click the quick Edit option, we are unable to use and click the Edit icon to edit the item.

    For the new interface:

      ![](https://learn-attachment.microsoft.com/api/attachments/cebfae5d-e37b-4706-b13d-791e043437ee?platform=QnA)

    To further investigate this issue to determine the cause, we’d like to collect some additional information to check it from backend. To protect the privacy, I have sent you a private message to collect the information. You can access the private message via the link below:

    https://answers.microsoft.com/en-us/privatemessages/list

    Thanks,

    Kerwin

    0 comments No comments