Problem with Python runbook on Azure Autmation Accounts: script does not wait for a code to execute (?)

Anonymous
2021-07-29T06:54:40.143+00:00

In runbook's code there is a fragment where it installes a python library with pip module. While executing it script should wait until it is done, but it does not. Locally when I run "pip.main(['download', '-d', '.', 'pandas'])" it takes few seconds until it gets executed, in Azure just the beginning of output is shown and then it goes without waiting for it to finish.

Azure Automation
Azure Automation
An Azure service that is used to automate, configure, and install updates across hybrid environments.
1,138 questions
{count} votes

Accepted answer
  1. SwathiDhanwada-MSFT 17,881 Reputation points
    2021-08-04T10:22:50.077+00:00

    @Anonymous I have tested it from my end. Using runbook I tried to import pandas package and I was able to download it without any issues. For your reference, adding images related to it.

    Input:

    120415-image.png

    Output :

    120483-image.png

    120410-image.png

    Imported Modules :

    120476-image.png

    There were no errors, warnings that were logged. Can you please elaborate your issue if you were prompted with errors?


0 additional answers

Sort by: Most helpful