Activate Windows server 2019 from evaluation version stuck and not working

WebberP 1 Reputation point
2021-08-02T14:53:08.347+00:00

Hi,

Before I start, here is some facts that might impact why it's not working and help the troubleshoot:

  • This server is running as a virtual machine inside XCP-NG
  • The evaluation period has expired.
  • There are pending updates but they also fail to install (and I though this might be due to the fact that it's not activated)
  • This machine is not a domain controller
  • The "Windows License Manager Service" is running

So I've tried to convert this evaluation setup using this handy guide : https://4sysops.com/archives/convert-windows-server-2019-evaluation-to-the-retail-edition
However the process got stuck at 10% and then the server restart automatically (presumably because it now shut down every 1h)

I thought maybe we can't migrate expired evaluation version, so I've setup a brand new server, did all the updates and ran the same command.
This time the process did complete, but upon restart when prompted the server is still showing up as unlicensed....

I'm running out of options so any help would be appreciated.
I've also looked at getting support from Microsoft directly but I can't find out how to contact them.

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,507 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. WebberP 1 Reputation point
    2021-08-03T11:21:02.72+00:00

    After many reboot and some persistance I've managed to get most of the windows updates done appart from that one:

    120120-screenshot-2021-08-02-at-145140.png

    This morning I though the server would be off again, but it was still on (hasn't shut down due to the 1h time limit on the eval version). The migration was still stuck at 10% though... so I cancelled it and ran it again.

    This time it went through until the end and was apparently successful :
    120174-screenshot-2021-08-03-at-121459.png

    Then when I typed Y to restart it applied the patch then shut down, however when starting up again I was granted with this message:

    120175-screenshot-2021-08-03-at-114555.png

    And Windows is still not activated or migrated to the standard version...