question

salzrat-2744 avatar image
1 Vote"
salzrat-2744 asked purpleBlood-0520 commented

Mobile Hotspot error and strange fix...

I got the following error:
"To share your connection, you need to add this feature to your cellular data plan first"
when trying to activate mobile hotspot on a Laptop with integrated LTE module. This occurred on two different laptops, and only with the SIM cards from one network operator. SIM cards from another operator worked fine. However, the offending SIM cards worked fine e.g. as a mobile hotspot in an iphone, and the operator confirmed that no tethering functionality was blocked, and referred me to Windows tech support.

After a lot of digging, I got this to work by creating a COSA customization package as described here:
https://docs.microsoft.com/en-us/windows-hardware/customize/desktop/customize-cosa

by extracting the existing COSA database, copying over the data for this operator in a new profile, and adding
<HotSpot>
<Enabled>True</Enabled>
<EntitlementRequired>False</EntitlementRequired>
</HotSpot>

to the package.

What is strange, however, is that I can now remove the provisioning package from the OEM directory, and the mobile hotspot continues to work.

I wonder why this error occurs at all. I have compared the original COSA database entries for the SIM card that works and where it doesn't, and couldn't find any relevant difference - none of the had the hotspot setting explicitly enabled.
Also, why can the error be permanently fixed using an OEM provisiong file just once? Will this set something in the registry that will not get deleted again when the provisioning file is removed again? If so, what?

It'd be great if I could get to the bottom of this, because the network operator claims he has nothing to with the problem at all, but I suspect all customers will be affected...

windows-10-network
· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi!
thanks, yes, this "solution" is referenced from several places on the web, but it doesn't apply. My network operator doesn't provide a dedicated app like the operator in that link, so the there are no options for privacy for the mobile connection...

0 Votes 0 ·

Hi, can you give me sample?

0 Votes 0 ·

I have solved it in the meantime. I had to simulate the installation of a mobile operator package in Windows, and after doing that once, it worked (even after removing this again).

0 Votes 0 ·
Show more comments

after several frustrated attempts I think your solution is the right one but I find it super complex as a non-IT guy to to all the steps. Cant you just share the provisioning package that includes the answer file?

0 Votes 0 ·

Please how do I go about implementing the solution referred to in the link, it looks like lines of code and I don't know anything about it.

0 Votes 0 ·

1 Answer

francescoperfetto-9416 avatar image
0 Votes"
francescoperfetto-9416 answered salzrat-2744 commented

Hello,
I found a similar problem to yours on the Italian Microsoft community. You can try if that solution is also valid for you:
https://answers.microsoft.com/en-us/windows/forum/all/to-share-your-connection-you-need-to-add-this/31bf2ae8-3a38-4de8-a07c-a04090d6dee9

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi!
thanks, yes, this "solution" is referenced from several places on the web, but it doesn't apply. My network operator doesn't provide a dedicated app like the operator in that link, so the there are no options for privacy for the mobile connection...

0 Votes 0 ·