registered VM to already existing hostpool but status "unavailable"

Samir Abdou 1 Reputation point
2021-08-10T13:23:02.84+00:00

Hey, i created a few VMs from a sysprepped image, then i followed this guide to re-register the VMs to the already existing hostpool.

The issue i ran into is that my VMs appear unavailable, and from time to time they turn available. I have tried restart the RDagent & Bootloader service but does not help.

Also tried to re-do the steps but does not seem to help either :(

122021-image.png

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,393 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. vipullag-MSFT 25,121 Reputation points
    2021-08-12T14:12:33.65+00:00

    @SamirAbdou-6436

    Firstly, apologies for the delay in responding here and any inconvenience this issue may have caused.

    Did you have the agent installed already before sysprep? If yes, this is not supported, please install the Agent after the VM has been deployed.


  2. Hubbaduba 1 Reputation point
    2022-10-25T20:06:30.633+00:00

    I found this from a previous search:

    Please follow below steps to add existing VM to Host pool, if you have removed the vm accidentally from host pool
    1.RDP into the existing VM you want to add to the host pool
    2.uninstall the two agents (go to >app and features> select 1.Remote desktop agent boot loader 2.Remote desktop service infrastructure agent (this will unregister with old host pool or even if you want to add to same host pool this step is mandatory

    *REBOOT otherwise, the installer does not prompt for the token
    3.Now install Azure Virtual Desktop Agent> apply the token

    0 comments No comments