SQL Server AAD Security Group Admin

Alex Ip 196 Reputation points
2021-08-11T15:55:19.153+00:00

I'm having trouble understanding how to login with SMSS when I created an AAD security group as the AAD admin.

122396-group.png

I get this error when I try to login with a user and password for a user in that security group, I also tried changing the database but I still get an error.

122405-image.png

Azure SQL Database
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,767 questions
0 comments No comments
{count} votes

Accepted answer
  1. Oury Ba-MSFT 16,731 Reputation points Microsoft Employee
    2021-08-11T18:09:00.127+00:00

    Hi @Alex Ip Thank you for posting your question. – it usually occurs when tenant is not reachable or SQL server does not have AAD Admin setup. I was able to reproduce the issue from my end.
    Please check the below

    1. Did you set allow Azure Services and resources to access this server
    2. Add client IP

    122408-image.png

    Please let me know if that does not help

    Regards,
    Oury


0 additional answers

Sort by: Most helpful