Getting sent back to the root folder when drilling into folder structure. SharePoint Online Modern document library

McClanahan, Richard@CIO 21 Reputation points
2021-08-11T21:35:25.963+00:00

to give a brief description,

  1. the Modern library has 114 document sets at the root level
  2. Inside the 114 document sets are 168,831 Items (lots of folders)
  3. none of the decoded paths I checked exceeded 400 characters, but I only checked a few
  4. The library does not inherit permissions
  5. No folders are exceeding the list view threshold
  6. As far as my testing, this only happens on a fresh page and the first time you drill into the folder, drill into it a second time and no issue, refresh the page and the problem comes back.
  7. Happens in Edge and Chrome

When drilling into random folders/Document sets users actually get bumped back to the root folder, sometimes from the first subfolder and other times, deeper into the folder structure. The users are reporting that this does not happen in Classic view and I confirmed as much.

Never seen this before, thanks for any help

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,834 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Allen Xu_MSFT 13,781 Reputation points
    2021-08-12T07:56:12.5+00:00

    Hi @McClanahan, Richard@CIO ,

    This issue is quite weird and I have never encountered such an issue before. Everything works normally on my end as per my test. And as you said, all factors like the amount of items, characters of URL path, list view threshold and so on are within the threshold. How long has this issue occurred? Would clear the browser cache help? If using IE, would the issue still persist?


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.