MARS Register Server Wizard fails - "encountered an internal error"

Tanner Wood 101 Reputation points
2021-08-14T02:03:58.243+00:00

One of my servers fails to register with my recovery fault. The vault credentials are valid and after I set an encryption phrase and a local place to store that phrase it tells me "internal error - try again later". The full error message is :

The activation did not complete successfully. Microsoft Azure Backup encountered an internal error. Wait for a few minutes and then try the operation again. If the issue persists, please contact Microsoft support.

Following the online troubleshooting of this error it states that the onlinebackup,kek file may not be present in the scratch folder. My scratch folder is empty but the MARS installer had no errors. Copying this file from another server running MARS had no change to the register error. The other troubleshooting options for this error are in regard to lack of disk space which is not an issue. I have fully uninstalled MARS, rebooted, and reinstalled with the same issue both times.

How can I resolve this error and complete the registration process? I need to start backups from this server as soon as possible so I can phase out the existing backup software. The server is not listed in my Azure Portal at all so I know it has not partially registered.

Thanks to anyone who can assist!

Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
1,140 questions
{count} votes

Accepted answer
  1. Tanner Wood 101 Reputation points
    2021-08-20T12:15:23.137+00:00

    I wanted to provide an update on this in hopes it may help someone else with the same issue.

    Azure support team worked with me and we tried several things which continued to produce the same error. I was then asked to create another recovery services vault and use vault credentials file from the new vault to register the server. This was the solution which fixed the registration issue. Backups have been running for a few days now.

    I still do not understand what occurred with this server that prevented it from registering with my main recovery services vault however.

    Thank you to @SadiqhAhmed-MSFT for helping me to get in contact with Azure support team!

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful