Complance Error in MBAM Btlocker

RAMESH KUMAR 31 Reputation points

Hi getting below Compliance error and most of the cases system is encrypted but protection type is off and system showing non compliance , please suggest for solutions.
1-An unknown error has occurred.
2-No Error
3-System partition not available or large enough.
4-Unable to find compatible TPM(System is in encrypted state but protection is off)
5-Waiting for TPM auto provisioning.(Most of the System is in encrypted state but protection is off)

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,806 questions
{count} votes

3 answers

Sort by: Most helpful
  1. TmanFromZA 1 Reputation point

    Sorry, not answering your question, but Getting the same/similar.

    Machines are showing as "encrypted" in BitLocker, and also showing "encrypted" on the local device. But falls under non-compliant on MBAM

    Struggling to get an accurate reporting on this, as MBAM is unable to breakdown this reporting according to Computer details


  2. Christian 21 Reputation points MVP

    Hello @Rameshkumar Jatiya and @TmanFromZA ,

    I have written a comprehensive guide describing all the errors you have stated above. Kindly take a look at the following links below;

    Addressing error "System check found some issues during MBAM encryption: Fail, the Power cable must be connected":

    Below is how to determine why an MBAM protected device is non-compliant

    0 comments No comments

  3. Christian 21 Reputation points MVP


    For this specific issue, "Waiting for TPM auto-provisioning.(Most of the System is in the encrypted state but protection is off)". You will have to run this command get-tpm to determine if TPM Auto-provisioning is enabled or disabled.

    On Dell devices, this is automatically enabled starting from Windows 10 and if for some reason it is disabled, you can enable it using the following command: Enable-TpmAutoProvisioning Below is the link to a guide I have written on the resolution of this issue:

    0 comments No comments