cloudshell to use a particular vnet setup issue

David Shapiro 1 Reputation point
2021-08-18T19:08:22.053+00:00

Hello,

I am trying to follow directions in https://learn.microsoft.com/en-us/azure/cloud-shell/private-vnet to setup my cloudshell to use a particular vnet that I need to run some image building with packer. The issue is that when I go to shell.azure.com, click advanced settings, and select Show VNET Isolation settings, it changes the region from East US to some other region, and the Virtual Network textbox does not show. Sometimes I get lucky and see the Virtual network box, but then the textbox to enter storage account grays out. Is this a bug? I tried Edge, Chrome, and Firefox. I really want to have my cloud shell use the vnet in the resource group.

Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,194 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. suvasara-MSFT 10,011 Reputation points
    2021-08-19T09:41:01.557+00:00

    @David Shapiro , Apologies for the inconvenience caused. I have tested this from my side and experienced the same result. As this is still in preview, there might be some expected technical glitches. I would seek collaboration from our backend cloud shell team to troubleshoot this issue further. I will revert back asap with any findings/updates regarding this issue.

    ----------

    Please do not forget to "Accept the answer" wherever the information provided helps you to help others in the community.


  2. David Shapiro 1 Reputation point
    2021-08-19T13:30:54.343+00:00

    Can you validate whether the documentation is correct or the youtube video is correct-in that, doc says all regions accept India Central can do this, but the video seemed to indicate only US West.

    0 comments No comments

  3. Ion Drugalea 1 Reputation point
    2022-10-25T12:31:38.827+00:00

    Hi @davidShapiro, do you still have this problem or how did you solve it?
    I have the same issue in West Europe, the network profile textbox id grayed out

    Thx!

    0 comments No comments