Pipeline failure due to tenant and subscription

Sumit Kumar 96 Reputation points
2021-08-19T07:23:28.9+00:00

Running a Synapse Analytics pipeline throws an error -
"Message: You are currently logged-in to 72f988bf-86f1-41af-91ab-2d7cd011db47 tenant.
You don't have access to de106e66-e094-4ba2-ac16-6e11de9c465d subscription, please check if it is in this tenant.
All the subscriptions that you have access to in this tenant are =
[]."

The message doesn't make sense since the subscription has been created on the tenant stated above. They are both visible to me -

124538-image.png

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,474 questions
{count} votes

Accepted answer
  1. Sumit Kumar 96 Reputation points
    2021-08-31T12:58:17.737+00:00

    @HimanshuSinha-msft and @Ronen Ariely this was resolved today. A step linking the Synapse WS with Azure ML WS was not done, which was failing the access of the ML WS from the Synapse WS -

    https://learn.microsoft.com/en-us/azure/synapse-analytics/machine-learning/quickstart-integrate-azure-machine-learning#give-msi-permission-to-the-azure-ml-workspace

    Thanks for all the help.


3 additional answers

Sort by: Most helpful
  1. Ronen Ariely 15,096 Reputation points
    2021-08-24T06:02:12.047+00:00

    Good day,

    Please check this thread which seems like include the same exact issue and a solution which worked for the OP

    https://learn.microsoft.com/en-us/answers/questions/171465/problems-connecting-to-workspace-using-azure-machi.html

    Check the excepted answer there

    If this not solving your issue then please try to provide more information

    0 comments No comments

  2. Sumit Kumar 96 Reputation points
    2021-08-27T20:37:56.76+00:00

    Thanks @Ronen Ariely . I'm working on Azure Synapse, where I've created a pipeline over a Jupyter notebook that runs on a Spark cluster.

    If the notebook is triggered manually with the "Run All" button, it executes successfully. However if the notebook is executed via a scheduled trigger in the pipeline, it throws the error above. I tried the code below from the link you shared but it still failed with the same error as before -

    from azureml.core.authentication import InteractiveLoginAuthentication
    ia = InteractiveLoginAuthentication(tenant_id="72f988bf-86f1-41af-91ab-2d7cd011db47",force=True)

    You can find tenant id under azure active directory->properties

    ws = Workspace.get(name=workspace_name,
    subscription_id=subscription_id,
    resource_group=resource_group,
    auth=ia)

    I then tried a different approach, of authenticating with a Service Principal, but that too failed with the same error when executed via a scheduled pipeline trigger.

    So, in short, both auth methods, InteractiveLogin and ServicePrincipal succeed when the notebook is executed via "Run All", but fail when executed via a scheduled pipeline trigger.

    0 comments No comments

  3. Sumit Kumar 96 Reputation points
    2021-08-31T03:21:26.507+00:00

    A bit of further info - the subscription in question is one that's already been logged into. So I'm not sure why the notebook is even trying to login to it again.

    0 comments No comments