Remote desktop lossless image compression?

van der Heijden, Hendrik 1 Reputation point
2021-08-19T08:43:44.813+00:00

Hi.

I need an RDP connection between Win10 PCs (currently on 1909) where the image compression is lossless.
Lossless is required as it shall be used for medical images.
As this will be over a local GBit network link, data rate should not be a problem.

A default setup shows unacceptable artifacts.
I found this question: https://social.technet.microsoft.com/Forums/ie/en-US/531a882c-5a2f-4875-b2b1-a7f14903aead/lossless-compression-for-remote-desktop?forum=winserverTS
and tried configuring RemoteFX to lossless compression,
but when comparing screen shots taken locally and of the RDP window,
the images are not the same, so compression was NOT lossless.

How can I get perfect 24bit RGB reproduction of the local screen content over RPD?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,285 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Sam Rueby 1 Reputation point
    2022-08-23T15:29:55.103+00:00

    I think what you want is to open up Group Policy Editor:
    Computer Configuration > Policies > Administrative Template > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment

    Set Configure image quality for RemoteFX Adaptive Graphics to 'Enabled',
    Set Image Quality to "Lossless".

    Not recommended over a network.

    0 comments No comments

  2. van der Heijden, Hendrik 1 Reputation point
    2022-08-24T07:04:12.037+00:00

    Hi Sam,

    back when I wrote the question (on 1909) I tried the settings you propose and it was NOT lossless.
    Now I checked again on 20H2 and indeed I get lossless compression. Good.

    However, after a minute of trying, the RDP connection just locked up. Remote PC did not react to anything,
    and no screen update on client. Seems like it isn't that reliable. After reconnecting RDP, it worked well.

    0 comments No comments