Issue with add team member graph API in US Government (GCC High) tenant

Karthik Ramesh 11 Reputation points
2021-08-19T12:49:06.23+00:00

I am trying to make a Graph API call to add a member to a team in the US government (GCC high) tenant.

URL POST https://graph.microsoft.us/v1.0/teams/{team-id}/members

BODY

{
  "@odata.type": "#microsoft.graph.aadUserConversationMember",
  "user@odata.bind": "https://graph.microsoft.us/v1.0/users/{user-id}",
  "roles": []
}

The above request fails with a 404 Not Found error. There is no additional information in the error message. I have verified that the user id I am passing is correct. So that is not an issue.

The above request works fine in the case of a normal tenant where the graph endpoint URL ends with ".com" instead of ".us". I find that other graph requests related to teams work fine with the ".us" endpoint for the US government tenant.

Interestingly, after adding the member to the team using teams web interface I tried adding the member to a private channel using the below URL and with the same request body as above and it worked.

POST https://graph.microsoft.us/v1.0/teams/{team-id}/channels/{channel-id}/members

So I guess the issue here is specific to the US government tenant. Can someone please suggest a fix or workaround for this issue?

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
10,836 questions
Microsoft Teams Development
Microsoft Teams Development
Microsoft Teams: A Microsoft customizable chat-based workspace.Development: The process of researching, productizing, and refining new or existing technologies.
2,920 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. Karthik Ramesh 11 Reputation points
    2021-08-19T13:19:38.25+00:00

    @Wajeed-MSFT Hi. Looks like this issue was reported already in the below post. Any update on when this would be fixed?

    https://stackoverflow.com/questions/68277042/cannot-create-events-or-team-members-in-ms-graph-national-us-cloud

    1 person found this answer helpful.
    0 comments No comments