when trying to create token through postman for implicit flow getting error

Radha Rajendran 1 Reputation point
2021-08-19T18:26:52.933+00:00

It perfectly works on brower with a login. However when i try to create a token using postman for implicit flow i am getting that error. Let me know how should i generate proper token.

Request Id: 211e174d-4bed-4bd5-9e80-0689c8544500
Correlation Id: 0e54da4b-2a6b-4b0d-b4cf-82ff99f1d39d
Timestamp: 2021-08-18T20:57:26Z
Message: AADSTS700051: response_type 'token' is not enabled for the application.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,852 questions
{count} votes

1 answer

Sort by: Most helpful
  1. JamesTran-MSFT 36,481 Reputation points Microsoft Employee
    2021-08-20T21:17:19.19+00:00

    @Radha Rajendran
    Thank you for your post!

    Based off the error message you received, can you make sure that you enabled Access Tokens and ID Tokens with your Azure AD app registration? I also found within our OAuth2.0 Implicit Grant Flow documentation, that to successfully request an ID token and/or an access token, the app registration in the Azure portal - App registrations page must have the corresponding implicit grant flow enabled, by selecting ID tokens and access tokens in the Implicit grant and hybrid flows section.

    125125-image.png

    Additional Link that might help with your issue:
    response_type ‘token’ is not enabled for the application in Dynamics 365 and Postman connection

    If you're still having issues, can you share any documentation you followed or any screenshots of your issue, so I can gain a better understanding.

    If you have any other questions, please let me know.
    Thank you for your time and patience throughout this issue.

    ----------

    Please remember to "Accept Answer" if any answer/reply helped, so that others in the community facing similar issues can easily find the solution.

    1 person found this answer helpful.
    0 comments No comments