visio file,Visio cannot open the file or a component in the file because it is corrupt

Reza Esmaili 1 Reputation point
2021-08-19T19:28:25.057+00:00

I have a visio file, when I try to open it , I get a message says " Visio cannot open the file or a component in the file because it is corrupt". It happens a lot to me and I have lost a lot of info. I contacted microsoft office and they gave me some steps but it did not work, can someone help me?

Visio Management
Visio Management
Visio: A family of Microsoft products used to create diagrams and vector graphics.Management: The act or process of organizing, handling, directing or controlling something.
247 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Viki Ji_MSFT 4,421 Reputation points
    2021-08-20T03:24:44.057+00:00

    Hi @Reza Esmaili ,
    Welcome to Q&A forum!

    In order to better analyze this issue, please provide more information at your convenience.

    • Which version of Visio are you using?
    • How did you get this Visio file? From other users or created by yourself?
    • What is the file extension? What steps have you tried?

    Please try the following steps to check this issue.

    1. Save it as another format and save to another location.
    2. Copy it to another PC.
    3. Try to open Visio in safe mode: press Win + R, type visio /safe in the run box, and click Enter. Then open the file to check the issue.

    Besides, you could also check if the stpes in the following official articles is helpful.
    How to troubleshoot damaged drawings in Visio
    Visio cannot open the file

    Any updates, pelase let me know.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Reza Esmaili 1 Reputation point
    2021-08-23T15:04:14.44+00:00

    Thank you Vikiji for your help. I tried everything but it did not work. I created the file myself, I have Visio Plan 2. I tried to attach one of my corrupt files, but system does not allow me to attached .vsdx file. I changed125620-pfc-control.pdf the extension to .pdf and is attached .

    Thanks,
    Reza

    0 comments No comments