Access denied for every batch job

Lilly Boerrigter 1 Reputation point
2021-08-19T22:11:10.027+00:00

Even if the batch job only contains an echo hello and a pause. Of course if I run it as administrator it works, but for some of my apps this option is not available. None of my IDEs work, Arduino, Eclipse, or VScode. In particular, with VScode, the batch file in question is in the vscjava.vscode-java-debug-0.35.0 extension under the folder, scripts, called launcher.bat. I believe the problem started to be present since the recent Windows update, but I'm not sure. Some solutions I have tried is giving cmd.exe full control, giving the batch group access to cmd.exe, going to the to the properties of the scripts folder and giving myself full control, disabling windows defender, windows defender firewall, disabling windows defender via regedit, reinstalling the VScode JDK. If any solutions can be provided, I would be extremely grateful.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,835 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. MotoX80 32,326 Reputation points
    2021-08-20T12:27:30.76+00:00

    believe the problem started to be present since the recent Windows update,

    If the updates were the cause, there would be millions of users with the same problems. More than likely something you ran on your PC modified something. Let's run some tests to see if we can identify the root cause.

    Are you able to open a command prompt? Just a normal cmd.exe, do NOT "run as administrator".

    Run these commands and see what you get.

    set comspec  
    set pathext  
    assoc .bat  
    cd %temp%  
    echo @echo.Hello > test.bat  
    %windir%\system32\cmd.exe /c test.bat   
    call test.bat   
    

    Does it look like this? (With your username.) Can you post the results?

    125027-capture.jpg

    0 comments No comments