FSLogix Semaphore Timeout

Erik 1 Reputation point
2021-08-20T10:03:05.073+00:00

Hi all,

We have been experiencing this issue for months now and we can't get a real solution, other than redeploying entire servers.
At some point, our users are having logon issues when using FSLogix profiles on our RDS-hosts, running Server 2019.

After a while, ODFC or Profile containers are not loaded correctly, the FSLogix log shows The semaphore timeout period has expired

124997-image.png

Most of the time, the first (5 - 6) users are logged on correctly, any other user is having profile issues.
We reboot our hosts every night, ensuring everyone is logged off and no profiles are in use.

We have updated about everything, running latest OS with patches, latest FSLogix, latest Office 365. All no avail.

Anyone here with a fix ?

FSLogix
FSLogix
A set of solutions that enhance, enable, and simplify non-persistent Windows computing environments and may also be used to create more portable computing sessions when using physical devices.
475 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Pär H 1 Reputation point
    2022-12-12T10:03:02.23+00:00

    Hello, we are seeing the same error now on our 4 rd host setup. Did you ever find out whats was the cause of this?

    0 comments No comments

  2. B. Kipp 0 Reputation points
    2023-01-18T10:00:06.24+00:00

    Hi,

    hope this helps:

    Sometimes jobs mail fail with one of the following Windows errors:

    IRPStackSize is too small

    or

    Not enough server storage is available to process this command.

    Cause

    This error can be a bit confusing, as it is not related to disk space, rather it is caused when the IRPStackSize registry entry on the remote system is set too low.

    IRPStackSize represents the amount of stack locations allocated for the Input/Output Request Packet (IRP) stack in Microsoft operating systems. The value of your IRPStackSize influences the amount of allocated bits of memory your operating system can use to transport files or do any other sort of I/O operations within the system.

    Solution

    The solution is to increase the IRPStackSize in the remote system’s registry. Please be extremely careful when editing your registry, and when possibly make a backup before making any changes. For more information, please refer to the relevant Microsoft Knowledge Base articles on support.microsoft.com

    By default, the Windows IRPStackSize is 15, and the maximum value is 50. Microsoft also notes that values between 33 and 38 are not recommended.

    Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    If the IRPStackSize entry is not present in this subkey, follow these steps:

    Click Edit, point to New, and then click DWORD Value.

    Type IRPStackSize, and then press ENTER.

    Note Type IRPStackSize exactly as it appears. The value is case sensitive.

    Click IRPStackSize, click Edit, and then click Modify.

    In the Data Value box, type a larger value, and then click OK.

    For more information refer to following Microsoft KB article:

    https://support.microsoft.com/kb/106167

    0 comments No comments