Unable to connect to Azure DevOps from Azure Logic Apps

Andy Pham 1 Reputation point

Hello Microsoft,
I’m trying to queue Azure DevOps pipeline from Azure Logic App. When I create workflow, the connection is configured correctly without any issue. However, the project dropdown list is unable to populate team project and same as build definition id dropdown list. The organization downdrop list is populated correctly. I do have team project administrator to the team project, and do have logic app contributor. Here is an error I got. Please advise.

Could not retrieve values. Error code: ‘Unauthorized’, Message: ‘TF400813: The user ‘573f1013-71ca-6a2f-ac35-ba1bef678b59’ is not authorized to access this resource.
Azure DevOps ActivityId: 0ba5ef8c-4ac4-4810-bf92-7835ca5bf444
Details: TF400813: The user ‘573f1013-71ca-6a2f-ac35-ba1bef678b59’ is not authorized to access this resource.
clientRequestId: eae306a3-f638-424b-96e5-579a70c9dcf7’. More diagnostic information: x-ms-client-request-id is ‘F6A975D5-74AA-41E3-9DCA-70A508139387’.


Azure Logic Apps
Azure Logic Apps
An Azure service that automates the access and use of data across clouds without writing code.
2,892 questions
{count} votes

2 answers

Sort by: Most helpful
  1. MayankBargali-MSFT 69,421 Reputation points

    @Andy Pham As per the error message and looking into the logs I can see that the user that was autheticated with the devops connector doesn't have the required permission to list the project under the selectec organization name. I will suggest you to double check the permission on the organization level (that you have selected) to list the projects.

    If you have already verified the same then I will suggest you to reach out to devops experts here so they can assist/verify the permission :

    DevOps is currently not supported in the Q&A forums, the supported products are listed over here https://learn.microsoft.com/en-us/answers/products (more to be added later on).

  2. Mark Weitzel 1 Reputation point Microsoft Employee

    This oauth setting made it work for me


    0 comments No comments