Hello,
This appears to be an Outlook issue and is less related to Azure AD. I am re-tagging this as Outlook, but you may also want to check on Microsoft Answers. https://answers.microsoft.com/en-us/outlook_com/forum
If you're unable to access the delegates, you may also want to check out the support page for this issue.
From the guide:
Cause
Outlook can't correctly retrieve the delegate information from the local free/busy object in the mailbox. This issue may occur after the manager's or delegate's mailbox is moved to a new forest.
Resolution
To resolve this issue, set a new temporary delegate in the manager's mailbox by using Outlook Web App (OWA) to force updating of the local free/busy object. To do this, follow these steps:
Sign in to the mailbox through OWA.
Open the calendar.
Select Share from the menu at the top.
Enter a user or group, and then select Delegate from the drop-down menu.
Click Share, and then click Done.
The manager should now be able to return to Outlook to continue management of the delegates from the client.