Timeout creating an azure App Service Managed Certificate

asked 2021-08-22T01:08:12.597+00:00
Nicholas Elliott 6 Reputation points

We are trying to create an app service managed certificate to secure our custom domain with SSL. However, every time this is attempted we receive a timeout error.

For a bit more detail; the primary domain we want to use is currently successfully hosted on a different app service, successfully secured with an SSL certificate. This works great.

We want to migrate this domain from the current app service it points to, to a new one. For this new one we have added the custom domain. However, when we attempt to create the managed certificate, the operation starts... but never ends, and some hours later eventually times out.

Is this a known issue, or are we doing something wrong?

Azure Web Apps
Azure Web Apps
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,294 questions
1 vote

2 answers

Sort by: Most helpful
  1. answered 2021-08-23T10:12:48.17+00:00
    SnehaAgrawal-MSFT 11,101 Reputation points Microsoft Employee

    Further for free certificate there are some below limitations:
    • Does not support wildcard certificates.
    • Does not support usage as a client certificate by certificate thumbprint (removal of certificate thumbprint is planned).
    • Is not exportable.
    • Is not supported on App Service Environment (ASE).
    • Is not supported with root domains that are integrated with Traffic Manager.
    • If a certificate is for a CNAME-mapped domain, the CNAME must be mapped directly to <app-name>.azurewebsites.net.

    Also Note that The free certificate is issued by DigiCert. For some top-level domains, you must explicitly allow DigiCert as a certificate issuer by creating a CAA domain record with the value: 0 issue digicert.com.

    Let us know if issue remains.

    No comments

  2. answered 2021-10-18T01:22:34.6+00:00
    Luqman Hussain 1 Reputation point

    I have the same problem. it worked fine on one site but not on another. the www.domain.com cname worked when creating ssl for it. however when creating for just domain.com it timed out after having waited a long time. tried multiple times. same thing.

    on a different azure app service it worked for both no issues. cant see any obvious difference between their dns settings.

    No comments