SharePoint PDF preview not working

Len Cardinal (CCSI) 136 Reputation points
2021-08-23T13:25:30.363+00:00

We have some PDFs that are not rendering in SharePoint preview windows. Large percent of the text is not visible on the screen. The 'missing' text is actually present in the page source code, but is somehow hidden on the screen (z-order problem?).

The PDF's render fine directly in all browsers, as well as in all PDF editing apps.

We've tried different browsers, different machines, different networks, and in-private/incognito connections. None of this points to a browser specific issue or caching issue.

Has anyone seen this? The issue surfaced about a week and a half ago. We opened a support case with Microsoft but the experience has been bewildering, to say the least.

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,839 questions
{count} votes

Accepted answer
  1. Len Cardinal (CCSI) 136 Reputation points
    2021-08-27T13:39:50.247+00:00

    I have a support case open. Yesterday, MS Support acknowledged the issue, and said they are targeting the end of September for a fix. They 'archived' the case for the time being.

    I provided Support a few PDF's that exhibit the issue. It is only some PDF's. These PDF's are vendor invoices sent to us by various companies. We are seeing the issue invoices from specific vendors. I cannot tell what authoring tool was used to generate the offending PDF's. Regardless, the PDF's work fine outside of SharePoint preview.

    So we'll have to wait for MS to fix the issue.

    2 people found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. Allen Xu_MSFT 13,781 Reputation points
    2021-08-25T07:14:31.313+00:00

    Hi @Len Cardinal (CCSI) ,

    Thanks for your feedback. As per my test, I couldn't reproduce this issue on my end. As a workaround, I would suggest you use open > open in browser to preview the PDF file instead of using Preview button. Also, you can maintain collaboration with Microsoft support to troubleshoot this issue.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. YA 0 Reputation points
    2024-03-07T12:07:03.3666667+00:00

    We had a similar issue and it turned out the files were uploaded from a zipped/compressed folder, so decompressing them and uploading them again fixed it.

    0 comments No comments